5/29/2025 - System Outage - Global Protect

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted May 29, 2025 - 11:23 EDT

Investigating

Global Protect is experiencing some service interruptions causing users to be unable to access services. ITS is monitoring Global Protect for updates.

Thanks,
Help Desk and Services Center
Posted May 29, 2025 - 09:33 EDT
This incident affected: Global Protect.