2/11/2025 Phishing Attempts

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 14:22 EST

Investigating

ITS is investigating several phishing attempts. Any email with the subject; "Important Notice" coming from "IT Help Center" can be deleted. Please report emails with that subject and sender or any other suspicious emails to ITS. As a reminder, BCCC ITS will never send an email asking faculty, staff or students to fill out personal information, or information about your account.

Thanks,
Help Desk and Services Center
Posted Feb 11, 2025 - 21:51 EST
This incident affected: Employee Email and Student Email.